wordpress升级版本报错

2018年5月4日16:26:39 发表评论 299 阅读
摘要

强迫症,后台面板总是有一个角标1的样式,让我很不爽,于是动手升级WordPress,最新版本为WordPress4.9.5,既然更新版本,想必也是修复了之前版本不够完善的地方,所以没有理由不去升级,不过保险起见,在升级前还是要备份一下。

点击现在更新,然后WordPress报错了,提示我权限不一致,卡在了解压缩升级文件,然后安装失败,如图:

wordpress升级版本报错

权限问题就好办,直接改权限呗,命令行输入下面的命令:

cd /home/wwwroot/html  //切换到文件所在目录

chmod -R 777 wp-admin  //赋予权限777

chmod -R 777 wp-includes //赋予权限777

注意升级成功后,为安全考虑,记得更改权限为755:

chmod -R 755 wp-admin  //赋予权限755

chmod -R 755 wp-includes //赋予权限755

补充:如果再次升级依然出现权限不一致,只要依次更改该文件权限即可,WordPress的报错提示还是很友好的:

wordpress升级版本报错

最后如图:

wordpress升级版本报错

完。


 

 

  • 我的微信号
  • 有朋自远方来,不亦乐乎?
  • weinxin
  • 我的微信公众号
  • 添加公众号了解更多动态
  • weinxin
舍得

发表评论

不高兴 彩虹 吃瓜 丢翔 乖 滑稽 花心 惊哭 惊讶 挤眼 酷 伤心 帅吗? 礼物 玫瑰 怒 生气 喷 睡觉 太开心 小九九 啊
太阳 吐舌 委屈 笑眼 星星月亮 心碎 咦 阴险 疑问 真棒 偷笑 斜眼笑 震惊 略 哈欠 无奈哭 抠鼻 哼 期待 懒得理你 爱心 蜡烛