LNMP一键安装包降级php版本

2019年3月26日17:26:22 发表评论 阅读(135)

之前的php版本是7.2的,但是放了某些程序不兼容,因此就想通过降级到php7.0来实现程序可以运行。我的运行环境是军哥的lnmp一键安装包,所以如果同样环境并且有php降级需求的可以借鉴一下。

首先

找到install.sh文件的地址,一般在/root/lnmp1.4-full/install.sh,切换到此目录执行以下命令:

sudo ./install.sh 选择需要执行的版本序号

LNMP一键安装包降级php版本

等待安装结束,成功后会出现下图:

LNMP一键安装包降级php版本

然后

我们会发现在/usr/local/nginx/conf 下会多一个enable-php7.0.conf的文件,然后我们需要修改nginx.conf中的内容,找到nginx.conf文件中include enable-php.conf; 修改为include enable-php7.0.conf;

还有nginx.conf 中与php-fpm.conf 中关于php-cgi.sock的内容要一致,(比如nginx中版本是7.0,那么php-cgi.sock也要是7.0)不然打开网页会出现502的错误。

最后

停掉原版本的php /etc/init.d/php-fpm stop

注意

修改完.conf文件一定要记得重启该服务,我是直接运行sudo lnmp restart重启所有服务。

运行find / -name "php-fpm.conf"  可以快速查找指定文件路径

 

weinxin
微信小程序
互联网开发,终身学习者,欢迎您的关注!
舍得

发表评论

不高兴 彩虹 吃瓜 丢翔 乖 滑稽 花心 惊哭 惊讶 挤眼 酷 伤心 帅吗? 礼物 玫瑰 怒 生气 喷 睡觉 太开心 小九九 啊
太阳 吐舌 委屈 笑眼 星星月亮 心碎 咦 阴险 疑问 真棒 偷笑 斜眼笑 震惊 略 哈欠 无奈哭 抠鼻 哼 期待 懒得理你 爱心 蜡烛